Home > Error Cannot > Error Cannot Find Rubygems Update Path

Error Cannot Find Rubygems Update Path

Contents

Existing account User name or e-mail address Password Always use SSL (experimental!) NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? Since than the framework requires rubygems 1.3.1 to run. This is an archive from Rails Forum. if not check your gem-directory which can be found by running gem environment for me it is "/usr/lib/ruby/gems/1.8/gems/rubygems-update-1.3.1/bin/ update_rubygems" Report post Edit Delete Reply with quote Re: gem update problem Konstantin navigate here

I'll first ask the obvious; Have you been executing the commands with sudo? Reload to refresh your session. Thanks for the post, it was exactly the issue at hand. If you read default.rb (I am not at my ubuntu box as I write this) it seems that the rubygems guys know about the debian /var/lib/gem path but don't adjust the

Error Cannot Find Rubygems Update Path

Installing ri documentation for actionpack-2.2.2... We recommend upgrading to the latest Safari, Google Chrome, or Firefox. Successfully installed mongrel-1.1.5 Successfully installed mongrel_cluster-1.0.5 2 gems installed Installing ri documentation for mongrel-1.1.5... Thanks!

This is not the normal problem! Could you suggest a solution? $ lsb_release -a No LSB modules are available. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 140 Star 1,616 Fork 829 rubygems/rubygems Code Issues 106 Pull requests 39 Projects Or is everyone compiling 1.8.6, which is the recommend version for Rails 2.2?

Partindo de um Ubuntu 8.04 sem o Ruby [3] instalado, o procedimento é o seguinte: $ sudo apt-get install ruby irb rdoc... gem uninstall rubygems-update $ cd /var/lib/gems/1.8/gems/rubygems-update-* $ sudo ruby setup.rb $ gem -v 1.3.1 Posted by Sam Ruby at 21:00 OK, I had better luck with the following: $ sudo gem Re-update $ sudo gem update --system Updating RubyGems Nothing to update 6. http://help.rubygems.org/discussions/problems/1223-receiving-error-message-when-installing-gems mingle About Twitter Comments Register Statistics Archives Planet Code Rails RESTful Disclaimer HTTP RFC 2616 httpbis URI RFC 3986 URI Template HTML Working Group WHATWG Specs HTML 4.01 XHTML 1.0 Drafts

then exec "#{Gem.ruby} -S #{$PROGRAM_NAME} _#{$1}_" end update_dir = $LOAD_PATH.find { |fn| fn =~ /rubygems-update/ } if update_dir.nil? Posted by Boyang at 02:46 after updating gem using the update-rubygems gem, "gem list" show only an empty list. So we can either install a duplicate copy in a different path, or update the old version behind the back of whichever package system you use. Think it has something to do with ln -s Posted by Sonder at 09:29 Sun 22 Mar 2009 Sonder: update-alternatives --config gem Posted by Marlin at 07:47 Thu 30 Apr 2009

Gem Remove

Mac OSX Snow Leopard でRVMを使って1.8.7と1.9.xを共存 Mac OSX (Snow Leopard) で、MacPortsのRuby1.8.7を使っているが、1.9.2も使いたいので、RVMでRuby1.9.2をインストールしてみた。 RVMのインストール $ bash &l …... 投稿ナビゲーション 前の投稿RVM, Ruby 1.8.7 and OSX Lion次の投稿cronでRVMのRubyを使う コメントを残す コメントをキャンセル メールアドレスが公開されることはありません。 * が付いている欄は必須項目ですコメント 名前 * メールアドレス * Draw an asterisk triangle Should I serve jury duty when I have no respect for the judge? Error Cannot Find Rubygems Update Path So I went for another solution, which installs more then necesary but is more straighforward: Install a more recent version of ruby + irb + rdoc + gem (side by side Rbenv Using CASE to select between two geometry functions?

Excerpt from Back In the Days.. http://megavoid.net/error-cannot/error-cannot-launch-xbmc-boxee-from-path-atv-flash.html That looks to be what you need to get rubygems-update to install. RubyGems can be updated \ using the official Debian repositories by aptitude or apt-get Solution: $ wget http://rubyforge.org/frs/download.php/45905/rubygems-1.3.1.tgz $ tar xzf rubygems-1.3.1.tgz $ cd rubygems-1.3.1 $ sudo ruby setup.rb $ gem Please `gem update --system` and try again. 9.

Installing RDoc documentation for activerecord-2.2.2... Posted by Scott Robinson at 20:48 Been there, done that. And since gem 1.3.1 has a totally... his comment is here Posted by James Abley at 20:58 Upgrading using apt-get install rubygems on 8.10 only brings you up to 1.2.0.

share|improve this answer edited Feb 23 '10 at 14:59 answered Feb 9 '10 at 16:15 Steve Madsen 8,79533658 1 Indeed, I believe I just succeeded with an update (under ruby Distributor ID: Ubuntu Description: Ubuntu 7.10 Release: 7.10 Codename: gutsy $ ruby -v ruby 1.8.6 (2007-06-07 patchlevel 36) [i486-linux] $ gem -v 1.2.0 $ sudo gem install rubygems-update Successfully installed rubygems-update-1.3.1 Posted by Tony at 02:01 I don't know about other systems, but for me, this is what works: sudo gem install rubygems-update sudo update_rubygems Posted by Bob Aman at 05:42 Wed

Excerpt from Comments on: Rails 2.1.2 and 2.2RC1: Update Your RubyGems at 20:15 Sat 17 Jan 2009 [rails][ruby]gemの1.3にあげれなかった railsを2.2.2にしたら empty?が未定義とかいわれた .Text - Error encountered なんか、2.1.2 にしたら script/generate ができなくなりました。 ruby script/generate model

at 08:15 Sat 28 Feb 2009 Chaps - you are missing something. Why are there so many different amounts received when receiving a payment? cheers! Everyone is...

Installing RDoc documentation for rubygems-update-1.3.5... Where are the oil platforms in Google Earth? would you mind marking my response as an answer please? –BigBrother Dec 24 '09 at 4:25 add a comment| up vote 5 down vote Similar problem, different solution $ sudo gem weblink Please `gem update --system` and try again.Any suggestions gratefully recieved,Cheers,Dang Posts [ 6 ] Pages 1 Rails Forum - Ruby on Rails Help and Discussion Forum »Setup and Configuration »Problem updating

There is simply a dependency cycle introduced by the release of hoe 2.3.0: rubygems-update 1.3.5 requires (among other things) hoe-seattlerb hoe-seattlerb requires hoe >= 2.3.0 hoe >= 2.3.0 requires rubygems >= Installing RDoc documentation for rake-0.8.3... RubyGems has already been updated. Excerpt from LifeAtMyMind at 20:46 Mon 12 Jan 2009 By: Ben Wagaman I am current using Ubuntu 8.10.

I think that on a debian box it should be like this... Could not find main page README Could not find main page README Could not find main page README Could not find main page README $ sudo update_rubygems Password: Error: Cannot find rubygems-update (1.3.1) ... $ gem environment RubyGems Environment: - RUBYGEMS VERSION: 1.2.0 - RUBY VERSION: 1.8.6 (2008-08-08 patchlevel 286) [i686-linux] - INSTALLATION DIRECTORY: /opt/ruby-enterprise-1.8.6-20080810/lib/ ruby/gems/1.8 - RUBY EXECUTABLE: /opt/ruby-enterprise-1.8.6-20080810/bin/ruby - EXECUTABLE Installing RDoc documentation for ruby-pg-0.7.9.2008.01.28... 12.

Could not find main page README Could not find main page README Could not find main page README Could not find main page README $ sudo update_rubygems Password: Error: Cannot find Posted by Mike at 20:32 Sat 21 Feb 2009 after updating gem using the update-rubygems gem, it was impossible to show "gem list" is the only output. Unfortunately Ubuntu 8.10 only has rubygems 1.2.0 in its repositories. Please `gem update --system` and try again.

E.g. For anyone else having this problem this is what I did that worked:1. Installing RDoc documentation for mongrel-1.1.5... gem update $ sudo gem update --system Updating RubyGems Updating rubygems-update Successfully installed rubygems-update-1.3.5 Updating RubyGems to 1.3.5 Installing RubyGems 1.3.5 RubyGems 1.3.5 installed === 1.3.5 / 2009-07-21 Bug fixes: *

Attempted a more basic command $ script/console Loading development environment (Rails 2.3.3) Rails requires RubyGems >= 1.3.1 (you have 1.0.1). Physically locating the server How to determine enemy ammo levels How can I list two concurrent careers, one full time and one freelance, on a CV? This could take a while... Why IsAssignableFrom return false when comparing a nullable against an interface?

At least in this case, the code is clearly BAD. gem uninstall rubygems-update And I have found a similar problem here: http://www.ruby-forum.com/topic/149288#662187 But unfortunately no new solution.... gem list should show you rubygems-update (1.3.1) with that there should be the command update_rubygems available. It was working fine until I needed to update RubyGems 1.0.1 to 1.3.5.