Home > Error Cannot > Error Cannot Find Libpq-fe.h

Error Cannot Find Libpq-fe.h

Contents

trying anyway. In it, you'll get: The week's top questions and answers Important community announcements Questions that need answers see an example newsletter Visit Chat Linked 2 Migrating to the use of databases share|improve this answer answered Jul 30 '14 at 3:46 lucianosousa 3,17331117 How did you install postgres? Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/home/demonchand/.rvm/rubies/ruby-1.9.2-p0/bin/ruby --with-pg --without-pg --with-pg-dir --without-pg-dir --with-pg-include --without-pg-include=${pg-dir}/include --with-pg-lib --without-pg-lib=${pg-dir}/lib --with-pg-config --without-pg-config --with-pg_config --without-pg_config Gem files will remain installed navigate here

share|improve this answer answered Jan 26 '15 at 4:57 akbrown 111 add a comment| up vote 1 down vote For AltLinux the package postgresqlx.x-devel (in my case postgresql9.5-devel) must be installed: If building fails, please try again with --with-pg-config=/path/to/pg_config checking for libpq-fe.h... package. Already have an account? http://stackoverflow.com/questions/6040583/cant-find-the-libpq-fe-h-header-when-trying-to-install-pg-gem

Error Cannot Find Libpq-fe.h

sudo apt-get install postgis share|improve this answer edited Apr 25 '13 at 10:27 Aragon 17.9k33986 answered Apr 25 '13 at 9:40 Hendre 1 but where does that pull from? I like to use PostgreSQL but the problem is installing the pg gem. I actually installed PostgreSQL 9.1 through the Ubuntu software center, but then built GDAL, GEOS, and PostGIS from source. trying anyway.

no checking for style of include used by make... The output (about 100 lines of mostly incomprehensible statements) included about one dozen instances of the following error message: You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev share|improve this answer answered Sep 6 '13 at 0:27 Claus Due 875312 add a comment| up vote 2 down vote centOS 6.5 I create a file: $ sudo touch /etc/profile.d/psql.sh with ERROR: Error installing pg: ERROR: Failed to build gem native extension. /home/demonchand/.rvm/rubies/ruby-1.9.2-p0/bin/ruby extconf.rb checking for pg_config...

Please leave a comment if you need any additional information and I will update this post. Vertical align top in multicolumn Why IsAssignableFrom return false when comparing a nullable against an interface? gem install 'execjs' and gem install 'therubyracer' –Nick Woodhams Apr 26 '12 at 10:30 2 Works on Precise too. –Travis R Jun 6 '12 at 20:19 1 Please revise Ones I checked out the project I have detected that it uses PostgreSQL as their database driver.

share|improve this answer edited Jul 9 '15 at 23:32 answered Jan 16 '12 at 23:34 Michael Durrant 46.4k46188298 3 Right, the Ruby pg gem wraps the usual PostgreSQL C libraries i have install all the requirements i am trying to run a program or compile it i am getting this error the configure command works fine but make is giving me I checked out a new rails app called Brokenlifts. Why I failed to use the \foreach command to connect the points?

libpq-dev package. –mu is too short Jan 17 '12 at 3:12 Thanks mu I hope you're getting snow :) –Michael Durrant Jan 17 '12 at 3:59 1 Worked https://github.com/rstats-db/RPostgres/issues/21 Browse other questions tagged ruby-on-rails ruby-on-rails-3 postgresql rails-postgresql pg or ask your own question. Error Cannot Find Libpq-fe.h gcc -E checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for ANSI C header files... Don't forget to mark your answer as accepted.

which are both just symlinks to the versioned installation directories. check over here Ruby in Rails © 2016 • All rights reserved. yes checking for ngettext in libc... comments powered by Disqus Contact If you have something to say about the things you find on this web presence, don't hesitate to write me: matthias@wikimatze.de × Matthias Günther

with capistrano) the 'deploy' user. –Les Nightingill May 28 '15 at 12:36 2 bundle config build.pg --with-pg-config=/usr/pgsql-9.4/bin/pg_config solve i for me on Centos 7 –liloargana Jan 3 at 19:39 add UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list. you can find this with the command: $ sudo find / -iname pg_config after, save the file: $ sudo chmod +x /etc/profile.d/ruby.sh and try execute your command again. his comment is here Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

yes checking for msgfmt... /usr/bin/msgfmt checking for dcgettext... Symlink them in to a directory in your path and you should be good: ln -s /usr/pgsql-9.4/bin/p* /usr/local/bin. Train and bus costs in Switzerland Why are there so many different amounts received when receiving a payment?

I have to wait TWO days before accepting.

none needed checking dependency style of gcc... What are the drawbacks of the US making tactical first use of nuclear weapons against terrorist sites? If building fails, please try again with --with-pg-config=/path/to/pg_config checking for libpq-fe.h... As the error suggests, use the --with-pg-config option to install the gem: $ gem install pg --with-pg-config="/Library/PostgreSQL/9.1/bin/pg_config" Note that you may need to run updatedb if you have never used locate

I will reward the bounty as soon as SO will let me. –whargrove Mar 11 '15 at 3:24 worked for me as well, I'm running postgresql 9.3 on CentOS If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer. asked 1 year ago viewed 4144 times active 1 year ago Related 463Can't find the 'libpq-fe.h header when trying to install pg gem23gem install pg can not bind to libpq50gem install weblink It came from the different versions of the packages that were installed through the different users on the machine.

o checking whether we are using the GNU C compiler... trying anyway. This answer here helped me find the solution but the difference in package names required a bit of searching. Then I need to find out the pg-config path by sudo find / -name "pg_config", then do gem install pg -- --with-pg-config=/Library/PostgreSQL/9.4/bin/pg_config using the path I have just found out. –Yi

I could find the header libpq-fe.h, but somehow it didn't work.