Home > Error Cannot > Error Cannot Find Imap Library Libc-client.a

Error Cannot Find Imap Library Libc-client.a

Contents

This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Ask Ubuntu works best with JavaScript enabled Register Help Remember Me? Please check your IMAP installation. 2. http://megavoid.net/error-cannot/error-cannot-find-either-the-gdbm-or-the-db-library.html

Create symlinks for the errant files ln -s /usr/lib/x86_64-linux-gnu/libXpm.a /usr/lib/libXpm.a ln -s /usr/lib/x86_64-linux-gnu/libXpm.so /usr/lib/libXpm.so ln -s /usr/lib/x86_64-linux-gnu/liblber.a /usr/lib/liblber.a ln -s /usr/lib/x86_64-linux-gnu/libldap_r.a /usr/lib/libldap_r.a B. The PHP IMAP documentation will point you at the c-client library hosted on http://www.washington.edu/imap/ as a requirement. In most cases this sort of error will come down to a missing header or library and they're usually one of the first errors to appear. Check the path given to --with-kerberos (if no path is given, searches in /usr/kerberos, /usr/local and /usr ) The problem seems to be caused by mixture of 32bit and 64bit static http://php.net/manual/en/imap.requirements.php

Error Cannot Find Imap Library Libc-client.a

The build from source route If you already have another version of libc-client installed and you don't want to disturb it, or you don't have convenient access a pre-built version, you The previous messages suggest a link with IMAP and sure enough, there's a -with-imap lurking in your configure command. and nubs Search Main menu Skip to primary content Home Post navigation ← Previous Next → PHP5 with IMAP and SSL support Posted on April 28, 2011 by Mark Building your configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing.

This should not happen. This should not happen. Done Some packages could not be installed. By soirambo in forum System-Level Technical Discussion Replies: 1 Last Post: 01-23-2006, 05:32 PM FTP Problem, cannot login or list from several machines By ashworth102680 in forum DirectAdmin General Discussion Replies:

If you need to reset your password, click here. Scrolling back a little in the output might give you a clue though:- checking for IMAP support... and add the line extension=apc.so at the end of the file (you can also configure some additional APC settings): [...] extension=apc.so apc.enabled=1 apc.shm_size=128M apc.ttl=0 apc.user_ttl=600 apc.gc_ttl=600 apc.enable_cli=1 apc.mmap_file_mask=/tmp/apc.XXXXXX ;apc.mmap_file_mask=/dev/zero ;apc.shm_segments = my company yes checking for IMAP Kerberos support...

Results 1 to 8 of 8 Thread: PHP + IMAP on 64Bit machines Thread Tools Show Printable Version Email this Page… Display Linear Mode Switch to Hybrid Mode Switch to Threaded Is my teaching attitude wrong? In a first-time build, you must specify the system type so that the sources are properly processed. Please check your c-client installation.

danke für Rückantwort

Tutorials How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Ubuntu 12.04 LTS) - Page 3 > Log in with Facebook Log in with Are you new to LinuxQuestions.org? Error Cannot Find Imap Library Libc-client.a Reply With Quote 10-02-2007,06:36 AM #5 cpisuisse View Profile View Forum Posts Visit Homepage Verified User Join Date Jan 2007 Location Netherlands Posts 11 Hi again Frans, When i remove the Asking Client for discount on Ticket to amusement park Is a rest required at the end of the final measure of a piece?

Categories FAQ 21 FreeBSD 2 Linux 20 Windows 2 Zimbra 1 Categories FAQ (21) FreeBSD (2) Linux (20) Windows (2) Zimbra (1) How do I check over here Bookmark the permalink. 3 thoughts on “PHP5 with IMAP and SSL support” aa on July 11, 2013 at 3:01 PM said: tried on centos: error: Cannot find imap library (libc-client.a). If you don't have openssl compiled and installed in /usr/local/ssl create symlink:

ln -s /usr/lib64/openssl/engines/ /usr/local/ssl

3. Add --with-kerberos to your configure line.

Please check your c-client installation. Grab the latest version from »ftp://ftp.cac.washington.edu/imap/ and compile it. Check config.log for additional information. 123456 checking for IMAP support... http://megavoid.net/error-cannot/error-cannot-find-resource-vm-global-library-vm.html Originally Posted by FransVanNispen Hi Cees, It means that you either didn't do step 2, or something went wrong in that step as it is the basic fault to start with.

How do I input n repetitions of a digit in bash, interactively Allow multiple GUI elements to react dynamically to interaction with a single element Should spoilers and reverse thrust be By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. You might run into stuff like this (when reconfiguring php f.e.): configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing.

Related posts: Linux - Building libxml2 on Red Hat Enterprise Linux The pre-configuration script for libxml2 does a pretty good job, but it doesn't quite catch one missing dependency on RHEL

This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. Visit our contact page to leave him a message. Privacy Policy devsumo technotes PHP - Building PHP 5.4 with IMAP on Red Hat Linux Posted on December 22, 2013 | Leave a comment Adding IMAP support to your PHP build and add the line extension=memcached.so at the end of the file: [...] extension=memcached.so The ionCube Loader can be installed as follows: cd /tmp Next download and unpack the correct ionCube Loader

Fatal error. What's New? configure: error: Cannot find imap library (libc-client.a). weblink Fortunately there's a link to the latest imap.tar.gz which is the one go to for.

Not the answer you're looking for? Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ Tenant claims they paid rent in cash and that it was stolen from a mailbox. This should not happen.

configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. First things first, .. Posts: 16,276 Rep: Packages providing 'libc-client.a' , examples : Fedora, CentOS 6 : uw-imap-static CentOS 5 : libc-client-devel Debian, Ubuntu : libc-client2007e-dev knudfl View Public Profile View LQ Blog View So basically, here's what I did: A.

My math students consider me a harsh grader. gopkris2000 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by gopkris2000 06-29-2013, 07:12 AM #2 knudfl LQ 5k Club Registered: Jan 2008 We'll show you how to enable PHP-imap support for PHP 5 in Directadmin:1) Make sure you have pam-devel and rpm-build installed: # yum -y install pam-devel rpm-build 2) Get the imap-file For anyone used to the slick and easy configure -> make -> make install process though this one is a little old-school.